Aa
A
A
Close
Avatar universal
Red and White Blood Cells in urine but no bacteria growth
In May, I had unprotected sex with an old boyfriend.  A few weeks later I noticed a burning on the outside of my vagina lips near the urethra opening.  I went to a doctor who diagnosed a UTI and gave me Cipro.  After 5 days, I still had symptoms.  I was then prescribed another anitbiotic and sent for a urine culture.  The culture determined that I had white and red blood cells in my urine but no growth of bacteria fro 24-48 hours.  I then went to my OBGYN to have a pap smear and to be tested for chlamydia and gonnorhea.  Everything was fine.  Things seem to be ok for a while.

Currently, I have a new boyfriend who has had a vascetomy.  Well, last week, we had unprotected sex (lots of it and i know stupid) and he came inside of me.  I noticed blood on the sheets.  A few days later, I noticed a yellowish greenish color when I wiped but not really a disharge.  I decided to insert a tampon (I didn't have my period) to see if it was coming from my cervix.  I immediately took it out and it was a little green.  The next day, the same place on my vagina was burning.  I then tested my urine with the AZO strips and it came back positve for Leukocytes but negative for nitrates.  Do you think that whatever was wrong with me in May is still wrong with me?  Today it seems like I got my period (not sure yet kind of light) and it is not due for 5 days.

Any insight on what is happening is greatly appreciated.

Cancel
1 Answers
Page 1 of 1
Avatar universal
Test for gonorrhea, chlamydia and Trich
Comment
Cancel
Comment
Avatar universal
Comment
Comment
Comment
Post Comment
Your Answer
Avatar universal
Answer
Do you know how to answer? Tap here to leave your answer...
Answer
Answer
Post Answer
A
A
Blank
Weight Tracker
Weight Tracker
Start Tracking Now
Chlamydia Community Resources