Aa
A
A
Close
Avatar universal
2 failed FET with period 6 days after transfer
Hi,

This is my first time posting here and I'd love to hear from someone with a similar situation.  I had an ectopic in December, where I lost both of my tubes and started Ivf.  My first fet I started spotting on day 5 (pink in color) and slowly started full on period bleeding on day 9 (even while on progesterone),  my pregnancy test obviously came out negative.  My doctor said he didn't like the fact that I was bleeding on progesterone, but we continued on to my next fet cycle.  Unfortunately the same thing is starting to happen again, I'm on Day 6 after my fet, and I've been spotting again.  The doctors office has asked me to get my progesterone level checked this morning.  But I don't know why this keeps happening? I must also add, I had a hysteroscopy in November and there were no polyps, I have a tiny fibroid but the doctor said it won't get in the way.  I'm now thinking we can't afford to keep doing this with no fertility coverage and I am devastated with only 2 embryos left.  All of my embryos were pgd tested.  And good embryos.
Cancel
0 Answers
Page 1 of 1
Your Answer
Avatar universal
Answer
Do you know how to answer? Tap here to leave your answer...
Answer
Answer
Post Answer
A
A
Looking for a Doctor?
Shop for health care like an expert. Find the best doctors based on reviews from patients like you.
Pregnancy: Trying to Conceive (TTC) Community Resources
Top Trying to Conceive Answerers
5875562 tn?1410902486
Blank
miami, FL
973741 tn?1342346373
Blank
4769306 tn?1513206606
Blank
NC