Avatar universal
confused
I thought i was leaking fluid earlier iv been checked but im not loosing any water,but the m/w did a swab there was brown on it tho but all she sed was theres mucus On your cervix ,wats mucus, also iv come home & when i went toilet theres was a bit of red on the tissue & brown discharge is this normal as i had an internal around 4wk ago but dint get this afterwards. Im 37wk & having regular tightening that i was told to keep an eye on
Cancel
4 Answers
Page 1 of 1
Avatar universal
I just bin toilet again (morning wee) & therre was lots of jelly like stuff wen i wiped but dark brown again there was a thick clump of brown n the rest just slimy, tmi sorri, is this bcoz i had an internal yesterday ?
Comment
Cancel
Comment
Avatar universal
Comment
Comment
Comment
Post Comment
Avatar universal
Sounds like your losing your mucus plug.
Comment
Cancel
Comment
Avatar universal
Comment
Comment
Comment
Post Comment
1486020 tn?1354032075
I agree. Sounds like you're losing your mucus plug. I lost mine about 1-2 weeks before going into labor. But it's a sign things are progressing and your body is getting ready for that baby to come!
Comment
Cancel
Comment
Avatar universal
Comment
Comment
Comment
Post Comment
Avatar universal
Thats wat i was hoping ! Maybe the m/w disturbed my cervix n that caused it.  Thank u every1 im getting so excited as with my other 2 pregnancys i lost my plug the day before labour started,
Comment
Cancel
Comment
Avatar universal
Comment
Comment
Comment
Post Comment
Your Answer
Avatar universal
Answer
Do you know how to answer? Tap here to leave your answer...
Answer
Answer
Post Answer
A
A
Doctor Ratings & Reviews
Comprehensive info on 720K doctors.
Complete reviews, ratings & more.
Pregnancy: Ages 18-24 Community Resources