Aa
A
A
Close
Avatar universal
I have no uterus and I am having red and brown discharge?
I don't know what is wrong with me? I am 27yrs old and I had my tubes tied when I was 22yrs and my uterus taken out when I was 24yrs due to problems.  I know there is something wrong with the tube that goes from my kidney to my bladder, it has been hurting for a year now.  I finally went to the Dr. and was put on antibiotics and I have been good at least I thought I was.   A few days ago my right kidney tube starting hurting again and then today out of nowhere I when I went to the restroom I had blood and brown mucus when I wiped and my groin hurts, like a dull pain. I just assume its another bladder infection since I get them all the time.   Its Friday night and so instead of waiting to go the Dr I went ahead and went to the hospital and my urine results said that my test came back fine and that I do not have UTI.  I don't get it?? I have burning, but no itching and it hurts in my groin area and on top of that my the tube that connects my kidney and my bladder hurts?   They said it was a yeast infection and I know that is not what it is??  What is wrong with me, if I am not pregnant and I don't have a UTI then what is it???
Cancel
0 Answers
Page 1 of 1
Your Answer
Avatar universal
Answer
Know how to answer? Tap here to leave your answer...
Answer
Submit Answer
A
A
Recent Activity
Avatar f tn
Blank
msmccoy commented on Tired of Genital Burn...
27 mins ago
790669 tn?1465192699
Blank
Des_a_rae commented on Saw the babies again ...
38 mins ago
1591611 tn?1445373967
Blank
Vency commented on Saw the babies again ...
4 hrs ago
Blank
Menstrual Tracker
Track your cycles
Start Tracking Now
Blank
Weight Tracker
Reach your weight goals
Start Tracking Now
Top Women's Health Answerers
Women's Health Community Resources