Women's Health Community
UTI/Yeast Symptoms With No Positive Diagnosis?
About This Community:

A community for people with Women's Health-related concerns. Ask a question, join a conversation, share experiences.

Font Size:
A
A
A
Background:
Blank
Blank
Blank
Blank Blank

UTI/Yeast Symptoms With No Positive Diagnosis?

Hi there,
I had the Mirena IUD inserted 3 months ago. For over a month now, I have had many unpleasant things going on down there. First, I have had non-stop bleeding of sorts. It is brownish, and is barely enough to get on my underwear, but is always present. Second, I have been incredibly itchy just inside the opening to my vagina. Third, I have had UTI-like symptoms. The interesting thing is every 5 days or so, I get INCREDIBLY itchy (cannot be helped with Calmoseptene or Vagisil), and about an hour in, it begins to transition to UTI-symptoms. Have to pee every 10 minutes, feels like bladder is never empty, and painful. 4 hours later or so, all of the symptoms disappear, and I'm left with the slight itchyness, bleeding, and sometimes the tiniest bit of discomfort when peeing.

I am very prone to yeast infections and UTIs. I can say, this is much itchier than a normal yeast infection, and the UTI going away and then coming back is not a normal behavior.

I have been to my OB-GYN now multiple times. We did treat for a slight yeast infection with two Diflucan pills, but I saw no change in symptoms. Upon my last visit, they tested me for a UTI, a yeast infection, BV, pregnancy, and TSH levels. Some blood was in my urine, but otherwise everything else came back fine. They also looked to check the position of the IUD. The string is not where is should be, but an ultrasound confirmed that everything was in place. They started me on a low estrogen birth control to try to regulate the bleeding starting one week ago.

It's driving me nuts that they can't find what's wrong. I have not had sex in weeks (same partner for 3 years), I am not douching, going without underwear to bed, and wearing tampons and not wearing tampons (tried both scenarios). I'm hoping to find some answers here.

Here are some of the things that I have guessed. 1. String is lost up in my cervix and is cutting me...therefore causing bleeding. 2. I have a mild UTI. 3. The Mild UTI and the bleeding is leading to a change in my PH and causing the irritation and itchyness.

What are your thoughts?

Thank you so much,
-Mary
Tags: uti, yeast, iud
Avatar f tn
Hey I read ur story in my opinion I think u should take the IUD out for month or so until things are back to normal. Reinsert it and see what happends if this continues I think your better off without the IUD and off getting a different birth control method
Blank
Post a Comment
To
Recent Activity
334926 tn?1436815123
Blank
butterflybabies commented on photo
30 mins ago
2020005 tn?1464196836
Blank
KTowne commented on KeeLolo's status
2 hrs ago
790669 tn?1465192699
Blank
Des_a_rae commented on photo
2 hrs ago
Blank
Menstrual Tracker
Track your cycles
Start Tracking Now
Blank
Weight Tracker
Reach your weight goals
Start Tracking Now
Top Women's Health Answerers
4851940 tn?1385441629
Blank
jemma116
United Kingdom
973741 tn?1342346373
Blank
specialmom
136956 tn?1425609872
Blank
ticked
Mississauga, ON
Avatar f tn
Blank
old_before_my_time
134578 tn?1463413330
Blank
AnnieBrooke
OR
1340994 tn?1374197577
Blank
Caryopteris
Raleigh, NC
Women's Health Community Resources
Top Women's Health Answerers
4851940 tn?1385441629
Blank
jemma116
United Kingdom
973741 tn?1342346373
Blank
specialmom
136956 tn?1425609872
Blank
ticked
Mississauga, ON
Avatar f tn
Blank
old_before_my_time
134578 tn?1463413330
Blank
AnnieBrooke
OR
1340994 tn?1374197577
Blank
Caryopteris
Raleigh, NC