All Journal Entries Journals

13 dpo, still have pos hpts

May 27, 2012 - 0 comments

I did have some weird extremely light pinkish spotting discharge this morning. It wasn't a lot and I didn't see it anymore during the day.
Since I have been getting +'s from 9dpo I doubt it's implantation? Probably just pregnancy related.

I had trouble sleeping. I was SO tired this morning. I don't even remember when I took my temps. I just remember having 97.92 and 98.14. I stuck with the lower one but I don't know if I should have even put a temp down.

I am probably going to the doctors on wednesday to confirm the pregnancy for our insurance. My DH actually has some time off this week and if I chose to go next week I would have to drag my youngest with me. When I went earlier this year, before the mc, for the first time visit, the nurse actually got frustrated with us and instead of asking my DH to take her in the waiting room, she ratted on us to the doctor... So my doctor wanted to reschedule me for a different day, because this dumb nurse couldn't ask if we could take her to the waiting room. Which wouldn't of been a problem.
Anyway, I don't want that to happen again. And by going in wed, they could do a beta wed and fri, instead of having to wait until the following week. I don't know.
I just hope things come out right.
My hcg tests have been getting darker. The test line is just about as dark as the other line. My LH test was blazing positive yesterday and today.

Ovulation Tracker
Post a Comment